Skip to main content
VulnerabilityPublished Updated

CVE-2025-37947: Linux kernel · ksmbd: prevent out-of-bounds stream writes by validating *pos

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High · fixed in 6.8.0-1046.49~22.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 16:39 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1046.49~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1046.53~22.04.1 +32
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1011.11~24.04.1
Fixed in
  • 6.14.0-1011.11~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms that updating the Linux kernel to the fixed versions and rebooting the system will remediate this vulnerability. Users should follow standard update procedures and recompile any third-party kernel modules due to ABI changes. No additional mitigations are specified or required beyond applying the official fix.

Description

A vulnerability in the Linux kernel's ksmbd component allowed out-of-bounds memory writes due to improper validation of the write offset in ksmbd_vfs_stream_write(). This flaw was fixed by adding a check to ensure the write position is within the valid stream length. The issue affects multiple specific Linux kernel versions and has a CVSS score of 8.8. A patch is available, and users should update and reboot to apply the fix.

References

Community reviews

Loading reviews…