CVE-2025-38006: Linux kernel · net: mctp: Don't access ifa_index when missing
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 5.15.0-186.196~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-186.196~20.04.1, 5.15.0-184.194~20.04.1, 5.15.0-1064.66~20.04.1 +43
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-100.100?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1046.49?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14@6.14.0-1011.11~24.04.1?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1046.52?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by Ubuntu in security notice USN-7699-1. Users should update their Linux kernel to the fixed versions provided by their distribution and reboot the system. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation is required beyond applying the official kernel updates.
Description
A vulnerability in the Linux kernel's Management Component Transport Protocol (MCTP) implementation was resolved. The issue involved accessing the ifa_index field in mctp_dump_addrinfo without verifying its presence, potentially leading to use of uninitialized memory. This flaw could cause a denial of service (system crash) but does not impact confidentiality or integrity. The vulnerability affects specific Linux kernel versions prior to 5.15.0-186.196 and certain exact versions listed. A patch is available and included in recent Ubuntu security updates.
References
- ubuntu.com/security/CVE-2025-38006 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38006 (opens in a new tab)
- git.kernel.org/linus/f11cf946c0a92c560a890d68e4775723353599e1 (opens in a new tab)
- git.kernel.org/stable/c/24fa213dffa470166ec014f979f36c6ff44afb45 (opens in a new tab)
- git.kernel.org/stable/c/acab78ae12c7fefb4f3bfe22e00770a5faa42724 (opens in a new tab)
- git.kernel.org/stable/c/d4d1561d17eb72908e4489c0900d96e0484fac20 (opens in a new tab)
- git.kernel.org/stable/c/f11cf946c0a92c560a890d68e4775723353599e1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7699-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7699-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7721-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8052-1 (opens in a new tab)