CVE-2025-38033: Linux kernel · x86/Kconfig: make CFI_AUTO_DEFAULT depend on !RUST or Rust >= 1.88
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 6.14.0-1013.13~24.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 16:39 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.14.0-1013.13~24.04.1, 6.14.0-1007.7, 6.14.0-1016.17~24.04.1 +3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-136.136?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1060.63?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1062.69?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating to the fixed Linux kernel versions. The fix makes FineIBT disabled by default when Rust is enabled unless Rust version 1.88 or later is used, which resolves the incompatibility. Users should upgrade to Linux kernel versions including this fix. Rust 1.88, scheduled for release in June 2025, also addresses the underlying issue in Rust's core library. No additional mitigations are required beyond applying the official kernel updates.
Description
A vulnerability in the Linux kernel's x86 architecture involving Control Flow Integrity (CFI) and Rust code interaction has been resolved. Specifically, calling core::fmt::write() from Rust code while FineIBT is enabled causes a kernel panic due to a Control Protection exception. This is because core::fmt::rt::Argument::fmt() disables CFI, conflicting with FineIBT's enforcement. The fix involves making the kernel configuration option CFI_AUTO_DEFAULT depend on Rust being disabled or Rust version 1.88 or higher, which addresses the incompatibility. The vulnerability affects multiple Linux kernel versions and has a medium severity rating with an impact on system availability due to kernel panics. A patch is available as part of Linux kernel updates.
References
- ubuntu.com/security/CVE-2025-38033 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38033 (opens in a new tab)
- git.kernel.org/linus/5595c31c370957aabe739ac3996aedba8267603f (opens in a new tab)
- git.kernel.org/stable/c/5595c31c370957aabe739ac3996aedba8267603f (opens in a new tab)
- git.kernel.org/stable/c/5a8d073d87da4ad1496b35adaee5719e94665d81 (opens in a new tab)
- git.kernel.org/stable/c/6b9956d09382bcbd5fd260c4b60ec48680a4cffb (opens in a new tab)
- ubuntu.com/security/notices/USN-7769-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7770-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7771-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7769-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7769-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7789-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7789-2 (opens in a new tab)