Skip to main content
VulnerabilityPublished Updated

CVE-2025-38092: Linux kernel · ksmbd: use list_first_entry_or_null for opinfo_get_list()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High · fixed in 6.14.0-1013.13~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.14.0-1013.13~24.04.1, 6.14.0-1007.7, 6.14.0-1016.17~24.04.1 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-136.136?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-9.9 – 6.8.0-136.136
53 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1060.63?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1008.8 – 6.8.0-1060.63
48 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14@6.14.0-1013.13~24.04.1?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1013.13~24.04.1
Fixed in
  • 6.14.0-1013.13~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1062.69?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1007.7 – 6.8.0-1062.69
39 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vulnerability has been fixed by updating the Linux kernel to versions that use list_first_entry_or_null() in the ksmbd subsystem. Users should update their Linux kernel to the fixed versions as per vendor advisories, such as Ubuntu Security Notice USN-7769-1. No additional mitigation is required beyond applying the official fix.

Description

A vulnerability in the Linux kernel's ksmbd component was resolved by replacing the list_first_entry() macro with list_first_entry_or_null() in the opinfo_get_list() function. The original macro could return an invalid pointer when the list was empty, potentially leading to system compromise. This issue affects multiple Linux kernel versions and has been addressed in official updates.

References

Community reviews

Loading reviews…