CVE-2025-38095: Linux kernel · dma-buf: insert memory barrier before updating num_fences
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1097.104~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1097.104~20.04.1, 5.15.0-1102.111~20.04.1, 5.15.0-1097.106~20.04.1 +59
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7699-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7699-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7721-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7933-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7938-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in Linux kernel version 6.14.0 and later. Users should update their systems using the official Ubuntu security notices USN-7699-1 and USN-7699-2, then reboot to apply the fixes. Due to an ABI change in the kernel update, recompilation and reinstallation of all third-party kernel modules are required. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed. No additional mitigation steps are indicated by the vendor.
Description
A vulnerability in the Linux kernel's dma-buf subsystem related to memory barrier insertion before updating num_fences has been resolved. The issue could cause a null pointer dereference due to memory update reordering. This vulnerability is part of a broader set of security issues fixed in the Linux kernel affecting multiple subsystems and architectures. The vulnerability has a CVSS 3.1 score of 7.8, indicating high impact on confidentiality, integrity, and availability. A patch is available and included in Linux kernel versions 6.14.0 and later for various Ubuntu releases. Users are advised to update and reboot their systems to apply the fixes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary.
References
- ubuntu.com/security/CVE-2025-38095 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38095 (opens in a new tab)
- git.kernel.org/linus/72c7d62583ebce7baeb61acce6057c361f73be4a (opens in a new tab)
- git.kernel.org/stable/c/08680c4dadc6e736c75bc2409d833f03f9003c51 (opens in a new tab)
- git.kernel.org/stable/c/3becc659f9cb76b481ad1fb71f54d5c8d6332d3f (opens in a new tab)
- git.kernel.org/stable/c/72c7d62583ebce7baeb61acce6057c361f73be4a (opens in a new tab)
- git.kernel.org/stable/c/c9d2b9a80d06a58f37e0dc8c827075639b443927 (opens in a new tab)
- git.kernel.org/stable/c/fe1bebd0edb22e3536cbc920ec713331d1367ad4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7699-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7699-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7721-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7933-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7938-1 (opens in a new tab)