Skip to main content
VulnerabilityPublished Updated

CVE-2025-38332: Linux kernel · scsi: lpfc: Use memcpy() for BIOS version

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 5.15.0-1092.99~20.04.1 : update Linux kernel when convenient.

Data as of 28 Oct 2026, 11:28 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1092.99~20.04.1, 5.15.0-1096.105~20.04.1, 5.15.0-1114.123~20.04.1 +64
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1015.15~24.04.1
Fixed in
  • 6.14.0-1015.15~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vulnerability is fixed in Linux kernel versions 5.15.0-1092.99~20.04.1 and later as listed in the established facts. Users should update to these fixed kernel versions to remediate the issue. No additional mitigation actions are required beyond applying the official kernel updates.

Description

CVE-2025-38332 is a vulnerability in the Linux kernel's SCSI lpfc driver where the BIOS version string handling uses strlcat() with FORTIFY support, causing a kernel panic due to perceived buffer overflow. The issue is fixed by replacing the strlcat() usage with memcpy() and ensuring proper null termination. This flaw affects multiple Linux kernel versions prior to fixed releases and can cause denial of service via kernel panic.

References

Community reviews

Loading reviews…