CVE-2025-38408: Linux kernel · genirq/irq_sim: Initialize work context pointers properly
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1105.112~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1105.112~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1114.123~20.04.1 +63
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7833-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7834-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7856-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel version 6.14.0 and corresponding Ubuntu kernel packages. Users should update their Linux kernel to version 6.14.0 or later and apply the vendor-provided package updates. After updating, a system reboot is required to apply the changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Follow the vendor advisory instructions for updating and rebuilding kernel modules as needed.
Description
A vulnerability in the Linux kernel's genirq/irq_sim subsystem was resolved by properly initializing work context pointers using kzalloc() instead of kmalloc(), preventing invalid pointer dereferencing. This flaw could lead to system compromise due to improper memory initialization. The issue affects numerous Linux kernel versions prior to 6.14.0 and has a CVSS score of 7.8, indicating high impact on confidentiality, integrity, and availability. A patch is available and should be applied to mitigate the risk. The vendor advisory from Ubuntu confirms the fix and recommends updating to the specified patched kernel versions.
References
- ubuntu.com/security/CVE-2025-38408 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38408 (opens in a new tab)
- git.kernel.org/linus/8a2277a3c9e4cc5398f80821afe7ecbe9bdf2819 (opens in a new tab)
- git.kernel.org/stable/c/19bd7597858dd15802c1d99fcc38e528f469080a (opens in a new tab)
- git.kernel.org/stable/c/7f73d1def72532bac4d55ea8838f457a6bed955c (opens in a new tab)
- git.kernel.org/stable/c/8a2277a3c9e4cc5398f80821afe7ecbe9bdf2819 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7834-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7833-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7856-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)