CVE-2025-38572: Linux kernel · ipv6: reject malicious packets in ipv6_gso_segment()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1097.104~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1097.104~20.04.1, 5.15.0-1102.111~20.04.1, 5.15.0-1097.106~20.04.1 +63
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7880-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7933-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been incorporated into Linux kernel version 6.14.0 and related package updates as detailed in the Ubuntu security advisories USN-7879-1 and USN-7879-2. Users should update their Linux kernel to version 6.14.0 or later and reboot their systems to apply the fix. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow vendor instructions for updating and rebuilding kernel modules accordingly.
Description
A high severity vulnerability (CVE-2025-38572) in the Linux kernel's IPv6 networking code was resolved. The flaw involved the ipv6_gso_segment() function improperly handling packets with very long IPv6 extension headers, leading to an overflow of the skb->transport_header field. This vulnerability could allow local attackers with certain privileges to cause memory corruption. A patch has been released and is included in Linux kernel version 6.14.0 and later updates. Users should update their Linux kernel to the fixed versions to mitigate this issue.
References
- ubuntu.com/security/CVE-2025-38572 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38572 (opens in a new tab)
- git.kernel.org/linus/d45cf1e7d7180256e17c9ce88e32e8061a7887fe (opens in a new tab)
- git.kernel.org/stable/c/5489e7fc6f8be3062f8cb7e49406de4bfd94db67 (opens in a new tab)
- git.kernel.org/stable/c/573b8250fc2554761db3bc2bbdbab23789d52d4e (opens in a new tab)
- git.kernel.org/stable/c/d45cf1e7d7180256e17c9ce88e32e8061a7887fe (opens in a new tab)
- git.kernel.org/stable/c/de322cdf600fc9433845a9e944d1ca6b31cfb67e (opens in a new tab)
- git.kernel.org/stable/c/ee851768e4b8371ce151fd446d24bf3ae2d18789 (opens in a new tab)
- git.kernel.org/stable/c/ef05007b403dcc21e701cb1f30d4572ac0a9da20 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7880-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7879-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)