CVE-2025-38614: Linux kernel · eventpoll: Fix semi-unbounded recursion
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1097.104~20.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:27 UTC
- Patch
- Available – fixed in 5.15.0-1097.104~20.04.1, 5.15.0-1102.111~20.04.1, 5.15.0-1097.106~20.04.1 +58
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7933-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7938-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple Linux kernel versions including 5.15.0-1097.104~20.04.1 and later. Users and administrators should update affected Linux kernel packages to these fixed versions as provided by their distribution vendors, such as Ubuntu's security notice USN-7909-1. No additional mitigation steps are required beyond applying the official kernel updates.
Description
CVE-2025-38614 is a vulnerability in the Linux kernel's eventpoll subsystem where semi-unbounded recursion can occur due to insufficient depth checks in epoll instance graphs. This flaw allows epoll instances to form graphs deeper than the intended maximum, potentially leading to system compromise. The issue has been fixed by improving recursion depth checks and limiting the total path length between epoll nodes. Multiple Linux kernel versions prior to 5.15.0-1097.104~20.04.1 and related builds are affected. A patch is available and has been incorporated into several fixed kernel releases.
References
- ubuntu.com/security/CVE-2025-38614 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38614 (opens in a new tab)
- git.kernel.org/linus/f2e467a48287c868818085aa35389a224d226732 (opens in a new tab)
- git.kernel.org/stable/c/3542c90797bc3ab83ebab54b737d751cf3682036 (opens in a new tab)
- git.kernel.org/stable/c/f2e467a48287c868818085aa35389a224d226732 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7910-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7933-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7909-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7938-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)