Skip to main content
VulnerabilityPublished Updated

CVE-2025-38709: Linux kernel · loop: Avoid updating block size under exclusive owner

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1050.53~22.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +26
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-106.106?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-106.106
Fixed in
  • 6.8.0-106.106
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1050.53?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1050.53
Fixed in
  • 6.8.0-1050.53
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14@6.14.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.14.0-1007.7~24.04.1 – 6.14.0-1018.18~24.04.1
11 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1051.57?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1051.57
Fixed in
  • 6.8.0-1051.57
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions. The fix enforces exclusive ownership checks before allowing block size changes on loop devices, preventing the vulnerability. Users should update to patched kernel versions as per vendor advisories.

Description

A vulnerability in the Linux kernel loop device allows changing the block size underneath a mounted filesystem, causing a mismatch between the block device block size and the filesystem superblock. This mismatch can lead to warnings and potential instability. The issue is fixed by requiring exclusive ownership of the loop device to change its block size, preventing modifications when the device is exclusively owned by another entity such as a filesystem.

References

Community reviews

Loading reviews…