Skip to main content
VulnerabilityPublished Updated

CVE-2025-39716: Linux kernel · parisc: Revise __get_user() to probe user read access

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1046.49~22.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1046.49~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1046.53~22.04.1 +27
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • 6.14.0-1007.7~24.04.1 – 6.14.0-1018.18~24.04.1
11 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions to correct the __get_user() function's read access checks. The vendor advisory confirms that this issue is fixed in updated kernel releases. Users should update their Linux kernel to the patched versions as provided by their distribution vendors. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's PA-RISC architecture was resolved involving the __get_user() function, which failed to properly trigger read access interruptions at the user privilege level. This flaw allowed user code to access read-protected addresses via system calls. The issue was fixed by revising the function to correctly probe read access rights at privilege level 3 and return an error if access is not allowed. Multiple specific Linux kernel versions are affected. The vulnerability has a medium severity rating and a CVSS score of 5.5. A patch is available to address this issue.

References

Community reviews

Loading reviews…