Skip to main content
VulnerabilityPublished Updated

CVE-2025-39940: Linux kernel · dm-stripe: fix a possible integer overflow

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-39940

Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1050.53~22.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +26
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-106.106?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-106.106
Fixed in
  • 6.8.0-106.106
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1050.53?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1050.53
Fixed in
  • 6.8.0-1050.53
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14@6.14.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.14.0-1007.7~24.04.1 – 6.14.0-1018.18~24.04.1
11 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1051.57?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1051.57
Fixed in
  • 6.8.0-1051.57
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected Linux kernel versions. The Ubuntu security advisory USN-8095-1 confirms that this and other Linux kernel vulnerabilities have been fixed. System administrators should update their Linux kernel packages to the fixed versions provided by their distribution vendors. No additional mitigations are specified or required beyond applying the official fix.

Description

A medium severity integer overflow vulnerability was identified and fixed in the Linux kernel's dm-stripe component. The flaw occurs in the stripe_io_hints function when an excessively large chunk size causes an integer overflow, potentially leading to denial of service by improper setting of I/O limits. This issue affects specific Linux kernel versions listed and has been addressed in official patches.

References

Community reviews

Loading reviews…