Skip to main content
VulnerabilityPublished Updated

CVE-2025-39998: Linux kernel · scsi: target: target_core_configfs: Add length check to avoid buffer overflow

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:19 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1114.123~20.04.1 +69
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-6.6
Fixed in
  • 6.17.0-6.6
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.6
Fixed in
  • 6.17.0-1006.6
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Linux kernel versions 5.15.0-1100.107~20.04.2 and later. Users should apply the official kernel updates provided by their Linux distribution vendors, such as the Ubuntu security notice USN-8033-1. After updating, a system reboot is required to apply the fixes. No additional mitigation steps are necessary beyond applying the official patches.

Description

CVE-2025-39998 is a buffer overflow vulnerability in the Linux kernel's SCSI target subsystem, specifically in the target_core_configfs component. The flaw arises from improper length checking when formatting strings into a fixed-size buffer, potentially causing a buffer overflow error. This vulnerability has been fixed in Linux kernel versions 5.15.0-1100.107~20.04.2 and later. The issue has a high severity score and could lead to denial of service or system instability if exploited.

References

Community reviews

Loading reviews…