CVE-2025-40016: Linux kernel · media: uvcvideo: Mark invalid entities with id UVC_INVALID_ENTITY_ID
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-186.196~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 13:47 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-186.196~20.04.1, 5.15.0-184.194~20.04.1, 5.15.0-1064.66~20.04.1 +46
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-6.6?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1003.3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1006.6?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1003.3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1003.3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Linux kernel versions. The vendor advisory from Ubuntu confirms that this issue is fixed in updated kernel releases. Users should update their Linux kernel to a fixed version to mitigate this vulnerability.
Description
A vulnerability in the Linux kernel's media subsystem (uvcvideo driver) was resolved by marking invalid entities with the identifier UVC_INVALID_ENTITY_ID. According to the UVC 1.1+ specification, units and terminals must have a non-zero unique ID. Previously, invalid or duplicate IDs caused kernel warnings and potential instability. This fix prevents issues such as chains of entities referring to themselves and kernel warnings triggered by invalid entity references. The vulnerability affects multiple specific Linux kernel versions and has been addressed in updated kernel releases.
References
- ubuntu.com/security/CVE-2025-40016 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-40016 (opens in a new tab)
- git.kernel.org/linus/0e2ee70291e64a30fe36960c85294726d34a103e (opens in a new tab)
- git.kernel.org/stable/c/000b2a6bed7f30e0aadfb19bce9af6458d879304 (opens in a new tab)
- git.kernel.org/stable/c/0e2ee70291e64a30fe36960c85294726d34a103e (opens in a new tab)
- git.kernel.org/stable/c/0f140cede24334b3ee55e3e1127071266cbb8287 (opens in a new tab)
- git.kernel.org/stable/c/15c0e136bd8cd70a1136a11c7876d6aae0eef8c8 (opens in a new tab)
- git.kernel.org/stable/c/f617d515d66c05e9aebc787a8fe48b7163fc7b70 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8125-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8126-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8165-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8261-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)