Skip to main content
VulnerabilityPublished Updated

CVE-2025-40057: Linux kernel · ptp: Add a upper bound on max_vclocks

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-40057

Not known to be exploited · fixed in 6.8.0-1050.53~22.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +35

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The Ubuntu security advisory USN-8029-1 includes this fix as part of its Linux kernel updates. Users should update their Linux kernel to the fixed versions to remediate this vulnerability. No additional mitigation steps are indicated beyond applying the official kernel updates.

Description

A vulnerability in the Linux kernel's PTP (Precision Time Protocol) subsystem was addressed by adding an upper bound on the max_vclocks parameter. The issue involved insufficient validation of the max argument in max_vclocks_store, which could lead to improper memory allocation attempts via kcalloc when the value was too large. This flaw has been fixed by extending the guard to prevent excessively large values. The vulnerability affects multiple specific Linux kernel versions and has been patched in updated releases.

References

Community reviews

Loading reviews…