Skip to main content
VulnerabilityPublished Updated

CVE-2025-40082: Linux kernel · hfsplus: fix slab-out-of-bounds read in hfsplus_uni2asc()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 5.15.0-1111.118~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1111.118~20.04.1, 5.15.0-1116.125~20.04.1, 5.15.0-1111.121~20.04.1 +67
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Linux kernel versions 5.15.0-1063.63~20.04.1 and later (including other 5.15.0 series releases listed). Users should upgrade to these fixed kernel versions to remediate the vulnerability. No additional mitigation is required beyond applying the official kernel update.

Description

A slab-out-of-bounds read vulnerability in the Linux kernel's HFS+ filesystem driver (hfsplus_uni2asc function) was fixed. The issue arises because the function processes a unicode buffer pointer beyond allocated memory due to differences in structure sizes. This flaw was addressed by introducing separate wrapper functions to safely handle different unicode buffer structures and limit the length to a safe size.

References

Community reviews

Loading reviews…