Skip to main content
VulnerabilityPublished Updated

CVE-2025-40232: Linux kernel · rv: Fully convert enabled_monitors to use list_head as iterator

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 6.17.0-1008.8~24.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 17:16 UTC

Severity
Low

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1008.8~24.04.1, 6.17.0-1008.8, 6.17.0-1007.7~24.04.1 +5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-8.8
Fixed in
  • 6.17.0-8.8
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.6
Fixed in
  • 6.17.0-1006.6
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to the fixed kernel package versions provided by Ubuntu in advisories USN-7920-1 and USN-7920-2. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow standard Ubuntu update procedures to ensure the system is protected.

Description

A vulnerability in the Linux kernel related to inconsistent iterator usage in enabled_monitors_seq_ops has been resolved. The issue involved treating an iterator inconsistently as different data types, causing wrong type casting and system crashes. This flaw was fixed by fully converting enabled_monitors to use list_head as the iterator, ensuring consistency and preventing crashes. The vulnerability affects multiple Linux kernel versions, particularly in the linux-hwe-edge and related packages. Ubuntu has released patches addressing this and other kernel security issues, requiring system updates and reboots. Due to an ABI change, recompilation of third-party kernel modules is necessary after updating. No known exploits are reported in the wild, and the severity is assessed as low.

References

Community reviews

Loading reviews…