Skip to main content
VulnerabilityPublished Updated

CVE-2025-40353: Linux kernel · arm64: mte: Do not warn if the page is already tagged in copy_highpage()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 6.8.0-1050.53~22.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +35

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Ubuntu has released updated Linux kernel packages that fix this and other vulnerabilities. Users should upgrade to the fixed kernel versions as specified in the vendor advisory. No additional mitigation is required beyond applying the official updates.

Description

A vulnerability in the Linux kernel's arm64 architecture related to the Memory Tagging Extension (MTE) in the copy_highpage() function has been resolved. The issue involved a warning triggered when a page was already tagged during a repeated copy operation, which was due to a change in the migration process. This flaw was fixed by replacing the warning with a comment to prevent unnecessary alerts. The vulnerability affects multiple Linux kernel versions prior to 6.8.0-1049.49, 6.8.0-1050.53, 6.8.0-1051.57, 6.8.0-1052.55, and 6.8.0-106.106 for Ubuntu 22.04.1. The vendor has released patches addressing this and other kernel vulnerabilities.

References

Community reviews

Loading reviews…