CVE-2025-40356: Linux kernel · spi: rockchip-sfc: Fix DMA-API usage
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 6.17.0-1007.7~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8 +6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to the fixed Linux kernel versions 6.17.0-1007.7~24.04.1 or later, 6.17.0-1008.8~24.04.1 or later, 6.17.0-1008.8 or later, and 6.17.0-1011.11 or later as provided by the vendor. The Ubuntu security advisory USN-8029-1 includes this fix. No additional mitigation actions are required beyond applying the official kernel updates.
Description
A vulnerability in the Linux kernel's spi: rockchip-sfc driver was resolved by correcting improper DMA-API usage. The fix replaces an incorrect method of obtaining the DMA address with the proper dma_map_single() call, addressing a DMA-API debug warning related to syncing DMA memory not allocated by the driver. This issue affects certain Linux kernel versions prior to 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8, and 6.17.0-1011.11. The vulnerability has a CVSS score of 7.8, indicating high impact on confidentiality, integrity, and availability. A patch is available and included in updated Linux kernel releases.
References
- ubuntu.com/security/CVE-2025-40356 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-40356 (opens in a new tab)
- git.kernel.org/linus/ee795e82e10197c070efd380dc9615c73dffad6c (opens in a new tab)
- git.kernel.org/stable/c/22810d4cb0e8a7d51b24527e73beac60afc1c693 (opens in a new tab)
- git.kernel.org/stable/c/ee795e82e10197c070efd380dc9615c73dffad6c (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8030-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8048-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-3 (opens in a new tab)