CVE-2025-41118: Grafana Pyroscope · Incorrect Permissions
Affects Grafana PyroscopeSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.16.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.16.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Grafana Pyroscope to 1.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GrafanaPyroscope | Affected
| Fixed in
|
AI-suggested
A fix is available in Pyroscope versions 1.15.2 and later for the 1.15.x branch, 1.16.1 and later for the 1.16.x branch, and all 1.17.x versions. Users should upgrade to these fixed versions to remediate the vulnerability. Until upgrading, it is strongly recommended to limit network exposure of the Pyroscope API so that it is accessible only by trusted users or internal systems. This reduces the risk of unauthorized access to the secret_key via the API.
Description
Pyroscope is an open-source continuous profiling database. The database supports various storage backends, including Tencent Cloud Object Storage (COS). If the database is configured to use Tencent COS as the storage backend, an attacker could extract the secret_key configuration value from the Pyroscope API. To exploit this vulnerability, an attacker needs direct access to the Pyroscope API. We highly recommend limiting the public internet exposure of all our databases, such that they are only accessible by trusted users or internal systems. This vulnerability is fixed in versions: 1.15.x: 1.15.2 and above. 1.16.x: 1.16.1 and above. 1.17.x: 1.17.0 and above (i.e. all versions). Thanks to Théo Cusnir for reporting this vulnerability to us via our bug bounty program.
References
- grafana.com/security/security-advisories/cve-2025-41118 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-41118 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2458796 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-41118.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:24503 (opens in a new tab)