CVE-2025-43963: LibRaw · Out-of-bounds Read
Affects LibRawSource GCVE Database
Not known to be exploited · CVSS 2.9 Low : upgrade to 0.21.4 when convenient.
Data as of 30 Oct 2026, 00:17 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 2.9 |
|---|
- Patch
- Available – fixed in 0.21.4
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade LibRaw to 0.21.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LibRaw LibRaw | Affected
| Fixed in
|
AI-suggested
A fix is available in LibRaw version 0.21.4 and later. Users should upgrade to version 0.21.4 or newer to remediate this vulnerability. No other mitigations are indicated.
Description
CVE-2025-43963 is an out-of-bounds read vulnerability in LibRaw versions before 0.21.4. The flaw occurs in the phase_one_correct function within decoders/load_mfbacks.cpp due to unchecked split_col and split_row values during processing of the 0x041f tag. This can lead to reading memory outside the intended buffer.