CVE-2025-47422: Advanced Installer · Incorrect Privilege Assignment
Source CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 22.6 : patch affected systems soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 22.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
European organizations should take immediate steps to mitigate this vulnerability. First, they should upgrade Advanced Installer to version 22.6 or later once available, as this will contain the fix for the uncontrolled search path issue. If you cannot patch yet, organizations should restrict write permissions on directories that Advanced Installer searches for binaries, ensuring that standard users cannot write to these locations. Implementing application whitelisting and restricting execution of unauthorized binaries can also reduce risk. Additionally, monitoring for unusual binary execution patterns and privilege escalation attempts on endpoints can help detect exploitation attempts. Organizations should review deployment configurations to avoid running installers with SYSTEM privileges unnecessarily and consider isolating installation processes to minimize exposure. Finally, educating IT staff about this vulnerability and maintaining strong endpoint security controls will help reduce the attack surface.
Description
Advanced Installer before 22.6 has an uncontrolled search path element local privilege escalation vulnerability. When running as SYSTEM in certain configurations, Advanced Installer looks in standard-user writable locations for non-existent binaries and executes them as SYSTEM. A low-privileged attacker can place a malicious binary in a targeted folder; when the installer is executed, the attacker achieves arbitrary SYSTEM code execution.