Skip to main content
CVE-2025-4779VulnerabilityPublished

CVE-2025-4779: lunary-ai/lunary · Cross-site Scripting

Affects lunary-ai/lunarySource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.9.24 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.24
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade lunary-ai/lunary to 1.9.24.

Affected software

ProductAffectedFixed in
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threatsAffected
  • <1.9.24
Fixed in
  • 1.9.24

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade lunary-ai/lunary to version 1.9.24 or later, where this vulnerability is addressed. If upgrading is not immediately feasible, implement strict input validation and sanitization on the `v1/runs/ingest` endpoint to reject or properly encode any input that could be interpreted as executable code. Avoid using `dangerouslySetInnerHTML` or ensure that any use of it is accompanied by robust sanitization libraries such as DOMPurify to neutralize malicious scripts. Employ Content Security Policy (CSP) headers to restrict the execution of untrusted scripts and reduce the impact of potential XSS attacks. Regularly audit and monitor web application logs for suspicious activity related to this endpoint. Conduct security testing, including automated and manual penetration tests focused on XSS vulnerabilities, to verify the effectiveness of mitigations. Additionally, educate developers on secure coding practices to prevent similar issues in future releases.

Description

lunary-ai/lunary versions prior to 1.9.24 are vulnerable to stored cross-site scripting (XSS). An unauthenticated attacker can inject malicious JavaScript into the `v1/runs/ingest` endpoint by adding an empty `citations` field, triggering a code path where `dangerouslySetInnerHTML` is used to render attacker-controlled text. This vulnerability allows the execution of arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions.

References

Community reviews

Loading reviews…