Skip to main content
VulnerabilityPublished Updated

CVE-2025-48734: Apache Commons BeanUtils 1.x · Improper Access Control

Affects Apache Commons BeanUtils 1.xSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.11.0 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.0% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.commons/commons-beanutils to 1.11.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.commons/commons-beanutilspkg:maven/org.apache.commons/commons-beanutilsOther threatsAffected
  • <1.11.0
Fixed in
  • 1.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache Commons BeanUtils versions 1.11.0 and later, and 2.0.0-M2 and later. Users should upgrade to these fixed versions to remediate the vulnerability. Patch status is not explicitly stated in the input, but the affected versions are prior to these releases.

Description

CVE-2025-48734 is a high-severity improper access control vulnerability in Apache Commons BeanUtils 1.x before version 1.11.0 and 2.x before 2.0.0-M2. It allows attackers to access the class loader of Java enum objects via the 'declaredClass' property when property paths from external sources are passed directly to PropertyUtilsBean.getProperty() or getNestedProperty(). This vulnerability can lead to arbitrary code execution.

References

Community reviews

Loading reviews…