CVE-2025-49144: notepad-plus-plus · Least Privilege Violation
Affects notepad-plus-plusSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 8.8.2 soon.
Data as of 3 Nov 2026, 22:58 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.3 |
|---|
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2025-07-01.
- Patch
- Available – fixed in 8.8.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade notepad-plus-plus to 8.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| notepad-plus-plusnotepad-plus-plus | Affected
| Fixed in
|
AI-suggested
Upgrade Notepad++ to version 8.8.2 or later, where this vulnerability has been fixed. Users should avoid running installers from untrusted directories or sources and be cautious of social engineering attempts that may trick them into executing malicious files alongside legitimate installers.
Description
Notepad++ versions 8.8.1 and earlier contain a privilege escalation vulnerability in the installer due to insecure executable search paths. This flaw allows an unprivileged user to gain SYSTEM-level privileges by placing a malicious executable in the same directory as the legitimate installer. The issue is fixed in version 8.8.2.
References
- github.com/notepad-plus-plus/notepad-plus-plus/security/advisories/GHSA-9vx8-v79m-6m24 (opens in a new tab)
- github.com/notepad-plus-plus/notepad-plus-plus/commit/f2346ea00d5b4d907ed39d8726b38d77c8198f30 (opens in a new tab)
- drive.google.com/drive/folders/11yeUSWgqHvt4Bz5jO3ilRRfcpQZ6Gvpn (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-49144-detect-notepad-vulnerability (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-49144-mitigate-notepad-vulnerability (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-49144-detect-notepad-vulnerability-1 (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-49144-mitigate-notepad-vulnerability-1 (opens in a new tab)