CVE-2025-50460: ms-swift project · Deserialization of Untrusted Data
Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 2.6% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
To mitigate this vulnerability, European organizations should: 1) Immediately audit all uses of PyYAML in their codebases, especially scripts or applications that load YAML files from untrusted sources. 2) Upgrade PyYAML to version 5.4 or later, which addresses unsafe deserialization issues. 3) Replace all instances of yaml.load() with yaml.safe_load() to restrict deserialization to safe Python objects. 4) Implement strict input validation and integrity checks on YAML configuration files, ensuring only trusted and verified files are processed. 5) Restrict access to configuration files and the execution environment to minimize the risk of malicious file injection. 6) Monitor logs and system behavior for unusual activity indicative of exploitation attempts. 7) Incorporate security testing focused on deserialization vulnerabilities in development and deployment pipelines. 8) Educate developers and DevOps teams about the risks of unsafe deserialization and secure coding practices related to YAML processing.
Description
A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.