Skip to main content
VulnerabilityPublished Updated

CVE-2025-52465: org.geoserver.web:gs-web-app · External Control of File Name or Path

Affects org.geoserver.web:gs-web-appSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 2.27.3 or 2.26.4 soon.

Data as of 1 Nov 2026, 22:57 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.27.3, 2.26.4
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-sec-core and org.geoserver.web/gs-web-app to 2.27.3 or 2.26.4.

Affected software

ProductAffectedFixed in
geoserverorg.geoserver.web:gs-web-appAffected
  • >=2.27.0 <2.27.3
Fixed in
  • 2.27.3
geoserverorg.geoserver.web:gs-web-appAffected
  • <2.26.4
Fixed in
  • 2.26.4
geoserverorg.geoserver.web:gs-web-sec-coreAffected
  • >=2.27.0 <2.27.3
Fixed in
  • 2.27.3
geoserverorg.geoserver.web:gs-web-sec-coreAffected
  • <2.26.4
Fixed in
  • 2.26.4
Mavenorg.geoserver.web/gs-web-apppkg:maven/org.geoserver.web/gs-web-appOther threatsAffected
  • <2.26.4
  • <2.27.3
Fixed in
  • 2.26.4
  • 2.27.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GeoServer to version 2.26.4 or 2.27.3 or later, where this vulnerability is fixed. Alternatively, disable or completely remove the GeoServer web interface to prevent exposure to this vulnerability. Patch status is not explicitly confirmed in the vendor advisory, but fixed versions are clearly stated.

Description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a vulnerability exists that allows an authenticated administrator with access to GeoServer's security system to pass arbitrary file names to the Master Password Dump web page and create files containing the master password in plaintext. The provided file name must be an absolute path to the target file, the target file can not already exist and all parent directories must already exist. Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations where the web interface is either disabled or completely removed are not affected since the vulnerability exists in one of the web pages.

References

Community reviews

Loading reviews…