CVE-2025-53014: ImageMagick · Out-of-bounds Read
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 3.7 Low : upgrade to 7.1.2-0 or 6.9.13-26 when convenient.
Data as of 29 Oct 2026, 23:48 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 3.7 |
|---|
- Patch
- Available – fixed in 7.1.2-0, 6.9.13-26
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-0 or 6.9.13-26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagick ImageMagick | Affected
| Fixed in
|
AI-suggested
Upgrade ImageMagick to version 7.1.2-0 or later, or 6.9.13-26 or later, where the vulnerability is fixed. No other mitigations are indicated or necessary.
Description
CVE-2025-53014 is an out-of-bounds read vulnerability in ImageMagick affecting versions prior to 7.1.2-0 and 6.9.13-26. The flaw arises from an off-by-one error in the InterpretImageFilename function when processing format strings with consecutive percent signs (%%). This can lead to heap buffer overflow. The issue is fixed in versions 7.1.2-0 and 6.9.13-26.