CVE-2025-53020: Apache HTTP Server · Memory Leak
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.64 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 4.9% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade apache/httpd to 2.4.64.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The most effective mitigation is to upgrade all affected Apache HTTP Server instances to version 2.4.64 or later, which contains the fix for this memory leak vulnerability. Organizations should implement a robust patch management process to ensure timely deployment of security updates. In environments where immediate patching is not feasible, administrators should monitor server memory usage closely and consider implementing resource limits or automated restarts to mitigate potential DoS conditions. Network-level protections such as rate limiting, web application firewalls (WAFs), and intrusion detection systems (IDS) can help detect and block abnormal traffic patterns that might trigger the vulnerability. Additionally, conducting regular security audits and vulnerability scans can help identify outdated Apache versions. For critical infrastructure, deploying redundant servers and load balancers can reduce the impact of any single server failure. Finally, maintaining comprehensive logging and alerting on server performance metrics will enable rapid detection and response to exploitation attempts.
Description
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.