CVE-2025-5472: run-llama/llama_index · Uncontrolled Recursion
Affects run-llama/llama_indexSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.12.38 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.12.38
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade run-llama/llama_index to 0.12.38.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| run-llama run-llama/llama_index | Affected
| Fixed in
|
AI-suggested
European organizations should promptly upgrade run-llama/llama_index to version 0.12.38 or later, where the vulnerability is fixed. Until the upgrade is applied, implement input validation to limit the depth of JSON structures accepted by applications using this library. Employ application-layer firewalls or JSON schema validators that reject excessively nested JSON payloads. Monitor application logs for RecursionError or stack overflow exceptions indicative of exploitation attempts. Consider sandboxing or isolating JSON parsing components to contain potential crashes and prevent cascading failures. Educate developers on safe recursion practices and encourage use of iterative parsing techniques or libraries with built-in depth limits. For critical systems, conduct penetration testing to verify resilience against deeply nested JSON inputs. Maintain an inventory of all applications and services using run-llama/llama_index to ensure comprehensive patching. Finally, implement rate limiting and anomaly detection on endpoints accepting JSON input to reduce attack surface.
Description
The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.