Skip to main content
VulnerabilityPublished

CVE-2025-59554: Advanced Ads (WordPress plugin) · SQL Injection

Affects Advanced Ads (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.0.7 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Advanced Ads (WordPress plugin) to 3.0.7.

Affected software

ProductAffectedFixed in
Advanced Ads GmbHAdvanced Ads – TrackingAffected
  • ≥ n/a, < 3.0.7
Fixed in
  • 3.0.7

AI-suggested

If you cannot patch yet, users should consider restricting access to the affected component and monitor for suspicious activity. Avoid exposing the vulnerable service to untrusted networks.

Description

CVE-2025-59554 is a critical unauthenticated SQL Injection vulnerability affecting Advanced Ads – Tracking versions prior to 3.0.7. This flaw allows an attacker to inject SQL commands without authentication, potentially leading to high confidentiality impact and limited availability impact.

References

Community reviews

Loading reviews…