CVE-2025-62188: Apache DolphinScheduler · Information Exposure
Affects Apache DolphinSchedulerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache DolphinScheduler to 3.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache DolphinScheduler | Affected
| Fixed in
|
Mavenorg.apache.dolphinscheduler/dolphinschedulerpkg:maven/org.apache.dolphinscheduler/dolphinschedulerOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache DolphinScheduler version 3.2.0 or later, where this vulnerability is fixed. For users unable to upgrade immediately, restrict the exposed management endpoints by setting the environment variable MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus or by adding the equivalent configuration in application.yaml under management.endpoints.web.exposure.include. Patch status is not explicitly confirmed; users should verify the latest vendor advisory for official fixes.
Description
CVE-2025-62188 is a high-severity vulnerability in Apache DolphinScheduler version 3.1.0 that allows unauthorized actors to access sensitive information, including database credentials. This exposure of sensitive information (CWE-200) can lead to confidentiality breaches. The vulnerability affects management endpoints that are overly exposed by default. Users are advised to upgrade to version 3.2.0 or later to remediate the issue. As a temporary workaround, restricting exposed management endpoints via environment variables or application configuration is recommended. No known exploits are reported in the wild.