CVE-2025-65104: FirebirdSQL firebird · Information Exposure
Affects FirebirdSQL firebirdSource CVE Database V5
Not known to be exploited · CVSS 7.9 High : upgrade to 4.0.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade firebird and firebirdsql/firebird to 4.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FirebirdSQLfirebird | Affected
| Fixed in
|
GitHubfirebirdsql/firebirdpkg:github/firebirdsql/firebirdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the Firebird client library to version 4.0.0 or higher, as this resolves the incorrect data length handling and prevents the information leak. Since no official vendor advisory or patch link is provided, confirm the upgrade path with FirebirdSQL official resources. Patch status is not explicitly confirmed beyond the upgrade recommendation, so verify current remediation guidance from the vendor before deployment.
Description
Firebird is an open-source relational database management system. In versions FB3 of the client library placed incorrect data length values into XSQLDA fields when communicating with FB4 or higher servers, resulting in an information leak. This issue is fixed by upgrading to the FB4 client or higher.