CVE-2025-65621: snipe-it · Improper Privilege Management
Affects snipe-itSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 8.3.4 when convenient.
Data as of 26 Oct 2026, 15:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.3.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade firef0x00/snipe-it to 8.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubfiref0x00/snipe-itpkg:github/firef0x00/snipe-itOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Snipe-IT to version 8.3.4 or later, where this vulnerability is fixed. Since this is a software vulnerability and not a cloud service, applying the official patch is necessary to remediate the issue. No other mitigations or workarounds are indicated.
Description
Snipe-IT before 8.3.4 allows stored XSS, allowing a low-privileged authenticated user to inject JavaScript that executes in an administrator's session, enabling privilege escalation.