CVE-2025-66168: Apache ActiveMQ · Integer Overflow or Wraparound
Affects Apache ActiveMQSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.4 Medium · fixed in 6.2.1 : update Apache ActiveMQ when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.1, 6.1.9, 5.19.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache ActiveMQ and Apache ActiveMQ All Module and Apache ActiveMQ MQTT Module and Apache Software Foundation/org.apache.activemq:apache-activemq and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:activemq-mqtt to 6.2.1, 6.1.9 or 5.19.2; org.apache.activemq/activemq to 5.19.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All Module | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All Module | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All Module | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should upgrade Apache ActiveMQ to version 5.19.2, 6.1.9, or 6.2.1 or later to address this vulnerability. The advisory notes that users of 6.x should upgrade to 6.2.4 or later as the fix was missed in earlier 6.x releases. No additional mitigation steps are indicated beyond applying the official patches.
Description
WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. See the following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046 Original Report: Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.