Skip to main content
VulnerabilityPublished

CVE-2025-66171: Apache CloudStack · Exposure of Private Personal Information to an Unauthorized Actor

Affects Apache CloudStackSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium.

Data as of 30 Oct 2026, 11:34 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CloudStackAffected
  • >=4.21.0.0 <=4.22.0.0
Fixed in–
Mavenorg.apache.cloudstack/cloudstackpkg:maven/org.apache.cloudstack/cloudstackOther threatsAffected
  • =4.21.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users of the CloudStack Backup plugin on versions 4.21.0.0 and 4.22.0.0 should upgrade to Apache CloudStack version 4.22.0.1, which contains the fix for this vulnerability. Patch status is not explicitly confirmed in the vendor advisory, but the recommended upgrade version addresses the issue. No additional mitigations are specified.

Description

The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can create new VMs using backups of any other user of the environment. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.

References

Community reviews

Loading reviews…