CVE-2025-66593: Synology Assistant · Origin Validation Error
Affects Synology AssistantSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 7.0.6-50085 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.6-50085
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade synology/synology-assistant to 7.0.6-50085.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SynologySynology Assistant | Affected
| Fixed in– |
Synologysynology/synology-assistantpkg:rpm/synology/synology-assistantOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict local user access to trusted personnel only and avoid running installation processes in untrusted environments.
Description
An origin validation error vulnerability in Synology Assistant before 7.0.6-50085 allows local users to write arbitrary files with restricted content and conduct denial-of-service during installation.