Skip to main content
VulnerabilityPublished

CVE-2025-67259: classroomio · CVE-2025-67259 is a Broken Access Control

Affects classroomioSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.1.13 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.13
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade classroomio/classroomio to 0.1.13.

Affected software

ProductAffectedFixed in
GitHubclassroomio/classroomiopkg:github/classroomio/classroomioOther threatsAffected
  • <0.1.13
Fixed in
  • 0.1.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the affected API endpoint where possible and monitor for suspicious activity involving API request manipulation. Avoid relying solely on client-side controls for access enforcement.

Description

CVE-2025-67259 is a Broken Access Control vulnerability in ClassroomIO v0.1.13 that allows an authenticated low-privileged student user to access unauthorized course-level information. By modifying intercepted API requests from POST to GET against the /rest/v1/course PostgREST endpoint, the attacker can retrieve sensitive data including other students' details, tutor and admin profiles, and internal course metadata. The vulnerability has a CVSS score of 6.5, indicating medium severity. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…