CVE-2025-67796: rdiffweb · Improper Access Control
Affects rdiffwebSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.10.6 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ikus-soft/rdiffweb to 2.10.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubikus-soft/rdiffwebpkg:github/ikus-soft/rdiffwebOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in IKUS Rdiffweb version 2.10.6. Users and administrators should upgrade to this version to remediate the improper authorization vulnerability. Until the upgrade is applied, restrict access tokens and monitor for suspicious activity related to unauthorized access attempts. Patch status is confirmed by the vendor's fix in version 2.10.6.
Description
IKUS Rdiffweb versions before 2.10.5 contain an improper authorization vulnerability that allows attackers with any valid or stolen access token to impersonate other users. The API fails to enforce proper binding between the authenticated user and the targeted user or tenant, enabling crafted requests to access or modify data belonging to other users and potentially perform privileged actions. This flaw may also allow cross-tenant data access. The issue is fixed in version 2.10.6.