CVE-2025-68204: Linux kernel · pmdomain: arm: scmi: Fix genpd leak on provider registration failure
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 11:07 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +65
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and included in updated Linux kernel packages for Ubuntu 20.04 HWE edge kernels. Users should apply the security updates provided by Ubuntu as detailed in advisory USN-8029-1 to remediate this issue. No additional mitigation steps are required beyond applying the vendor-supplied fixes.
Description
A memory leak vulnerability in the Linux kernel's ARM SCMI power domain driver was fixed. The issue occurs when of_genpd_add_provider_onecell() fails during probe, causing previously created generic power domains to not be removed. This can lead to a memory leak and potentially a kernel crash later in genpd_debug_add(). The fix adds proper error handling to release resources on failure. This vulnerability affects multiple Linux kernel versions prior to specific patched releases in the 5.15 series for Ubuntu 20.04 HWE edge kernels.
References
- ubuntu.com/security/CVE-2025-68204 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68204 (opens in a new tab)
- git.kernel.org/linus/7458f72cc28f9eb0de811effcb5376d0ec19094a (opens in a new tab)
- git.kernel.org/stable/c/18249a167ffd91b4b4fbd92afd4ddcbf3af81f35 (opens in a new tab)
- git.kernel.org/stable/c/582f48d22eb5676fe7be3589b986ddd29f7bf4d1 (opens in a new tab)
- git.kernel.org/stable/c/7458f72cc28f9eb0de811effcb5376d0ec19094a (opens in a new tab)
- git.kernel.org/stable/c/7f569197f7ad09319af960bd7e43109de5c67c04 (opens in a new tab)
- git.kernel.org/stable/c/921b090841ae7a08b19ab14495bdf8636dc31e21 (opens in a new tab)
- git.kernel.org/stable/c/983e91da82ec3e331600108f9be3ea61236f5c75 (opens in a new tab)
- git.kernel.org/stable/c/ad120c08b89a81d41d091490bbe150343473b659 (opens in a new tab)
- git.kernel.org/stable/c/c6e11d320fd6cbaef6d589f2fcb45aa25a6b960a (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8030-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8048-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-2 (opens in a new tab)