CVE-2025-68217: Linux kernel · Input: pegasus-notetaker – fix potential out-of-bounds access
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +74
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. The affected Linux kernel versions prior to 5.15.0-1097.100~20.04.1, 5.15.0-1103.110~20.04.1, 5.15.0-1103.112~20.04.1, 5.15.0-1110.119~20.04.1, and 5.15.0-173.183~20.04.1 have been fixed. Users should update to versions at or beyond these to remediate the vulnerability.
Description
A vulnerability in the Linux kernel's pegasus_notetaker driver allows out-of-bounds memory access due to improper buffer size validation when parsing USB interrupt packets. This issue arises from allocating a buffer based on a potentially malicious USB descriptor's wMaxPacketSize value, which can be very small, leading to unsafe parsing of packets with specific byte patterns.
References
- ubuntu.com/security/CVE-2025-68217 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68217 (opens in a new tab)
- git.kernel.org/linus/69aeb507312306f73495598a055293fa749d454e (opens in a new tab)
- git.kernel.org/stable/c/015b719962696b793997e8deefac019f816aca77 (opens in a new tab)
- git.kernel.org/stable/c/084264e10e2ae8938a54355123ad977eb9df56d6 (opens in a new tab)
- git.kernel.org/stable/c/36bc92b838ff72f62f2c17751a9013b29ead2513 (opens in a new tab)
- git.kernel.org/stable/c/69aeb507312306f73495598a055293fa749d454e (opens in a new tab)
- git.kernel.org/stable/c/763c3f4d2394a697d14af1335d3bb42f05c9409f (opens in a new tab)
- git.kernel.org/stable/c/9ab67eff6d654e34ba6da07c64761aa87c2a3c26 (opens in a new tab)
- git.kernel.org/stable/c/c4e746651bd74c38f581e1cf31651119a94de8cd (opens in a new tab)
- git.kernel.org/stable/c/d344ea1baf1946c90f0cd6f9daeb5f3e0a0ca479 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-3 (opens in a new tab)