CVE-2025-68231: Linux kernel · mm/mempool: fix poisoning order>0 pages with HIGHMEM
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.8.0-1050.53~22.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 13:47 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +40
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available from the vendor and should be applied to affected linux-aws kernel versions. The vendor advisory from Ubuntu confirms that this issue is fixed in updated kernel releases. Users should upgrade to the fixed kernel versions to remediate this vulnerability. No additional mitigation actions are indicated or required beyond applying the official fix.
Description
A vulnerability in the Linux kernel's memory pool (mempool) subsystem related to poisoning order>0 pages with HIGHMEM has been fixed. The issue caused kernel page faults due to improper handling of high-order pages in high memory, leading to kernel oops conditions. The flaw was due to the poisoning code not correctly managing CONFIG_HIGHMEM, accessing beyond the first mapped page. This has been addressed by updating the code to properly map, poison, check, and unmap individual pages. The vulnerability affects specific linux-aws kernel versions prior to 6.8.0-1049.49~22.04.1, 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1, and 6.8.0-106.106~22.04.1. A patch is available from the vendor.
References
- ubuntu.com/security/CVE-2025-68231 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68231 (opens in a new tab)
- git.kernel.org/linus/ec33b59542d96830e3c89845ff833cf7b25ef172 (opens in a new tab)
- git.kernel.org/stable/c/19de79aaea33ee1ea058c8711b3b2b4a7e4decd4 (opens in a new tab)
- git.kernel.org/stable/c/6a13b56537e7b0d97f4bb74e8038ce471f9770d7 (opens in a new tab)
- git.kernel.org/stable/c/a79e49e1704367b635edad1479db23d7cf1fb71a (opens in a new tab)
- git.kernel.org/stable/c/ea4131665107e66ece90e66bcec1a2f1246cbd41 (opens in a new tab)
- git.kernel.org/stable/c/ec33b59542d96830e3c89845ff833cf7b25ef172 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8125-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8126-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-5 (opens in a new tab)