Skip to main content
VulnerabilityPublished Updated

CVE-2025-68263: Linux kernel · ksmbd: ipc: fix use-after-free in ipc_msg_send_request

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1111.118~20.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1111.118~20.04.1, 5.15.0-1116.125~20.04.1, 5.15.0-1111.121~20.04.1 +71
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threatsAffected
  • <6.17.0-19.19
Fixed in
  • 6.17.0-19.19
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available from the vendor. Users should update their Linux kernel packages to the fixed versions listed in the Ubuntu security advisories USN-8094-1 and USN-8094-2 and reboot their systems to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigations are indicated by the vendor advisory.

Description

A critical use-after-free vulnerability (CVE-2025-68263) in the Linux kernel's ksmbd IPC subsystem was resolved. The flaw involved a race condition where ipc_msg_send_request() could free memory while another handler was still accessing it, leading to a slab-use-after-free detected by KASAN. This vulnerability affects Linux kernel versions prior to certain 5.15.x releases on Ubuntu 20.04.1. The issue has been fixed by ensuring proper locking around the shared data structures. The vulnerability has a CVSS score of 9.8, indicating high impact on confidentiality, integrity, and availability. A patch is available and users are advised to update and reboot to apply the fix. The vendor advisory also covers many other Linux kernel vulnerabilities fixed in the same update.

References

Community reviews

Loading reviews…