Skip to main content
VulnerabilityPublished Updated

CVE-2025-68284: Linux kernel · libceph: prevent potential out-of-bounds writes in handle_auth_session_key()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1103.110~20.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1114.123~20.04.1 +71
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threatsAffected
  • <6.17.0-19.19
Fixed in
  • 6.17.0-19.19
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available and should be applied promptly. The vendor advisory (Ubuntu Security Notice USN-8094-1) provides updates fixing this vulnerability. Systems running affected Linux kernel versions should be upgraded to the patched versions to mitigate the risk.

Description

A vulnerability in the Linux kernel's libceph component could allow out-of-bounds writes due to improper boundary checks on untrusted network packet data in the handle_auth_session_key() function. This issue has been resolved by adding boundary checks to prevent such writes when decrypting connection secrets or processing service tickets. The vulnerability has a high CVSS score of 9.8, indicating critical impact if exploited. Multiple affected Linux kernel versions prior to specific patch releases are identified. Official patches are available from the vendor.

References

Community reviews

Loading reviews…