Skip to main content
VulnerabilityPublished Updated

CVE-2025-68308: Linux kernel · can: kvaser_usb: leaf: Fix potential infinite loop in command parsers

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +70

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threatsAffected
  • <6.17.0-19.19
Fixed in
  • 6.17.0-19.19
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The issue is fixed in updated linux-hwe-edge kernel versions as per the Ubuntu security notice USN-8094-1. Users should upgrade to kernel versions at or beyond the fixed releases to remediate this vulnerability.

Description

A vulnerability in the Linux kernel's kvaser_usb driver could cause an infinite loop in command parsing due to improper handling of zero-length commands aligned on USB packet boundaries. This issue is fixed by adjusting the buffer position calculation to ensure progress in parsing. The flaw affects certain versions of the linux-hwe-edge kernel prior to specific patch releases. The vulnerability has been addressed in official Ubuntu security updates.

References

Community reviews

Loading reviews…