Skip to main content
VulnerabilityPublished Updated

CVE-2025-68726: Linux kernel · crypto: aead – Fix reqsize handling

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.17.0-1018.18 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1018.18, 6.17.0-1010.10~24.04.1, 6.17.0-1009.9~24.04.3 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <6.17.0-1009.9~24.04.2
  • <6.17.0-1010.10~24.04.1
  • <6.17.0-1009.9~24.04.3
  • <6.17.0-19.19~24.04.2
  • <6.17.0-1018.18
Fixed in
  • 6.17.0-1009.9~24.04.2
  • 6.17.0-1010.10~24.04.1
  • 6.17.0-1009.9~24.04.3
  • 6.17.0-19.19~24.04.2
  • 6.17.0-1018.18

AI-suggested

A fix has been implemented in the Linux kernel by properly initializing the reqsize field in AEAD algorithms during their initialization. Users and administrators should apply the official Linux kernel updates that include this fix. Patch status is not explicitly confirmed in the provided data; therefore, check the vendor or Linux kernel mailing lists for the latest patches and updates addressing CVE-2025-68726.

Description

In the Linux kernel, the following vulnerability has been resolved: crypto: aead - Fix reqsize handling Commit afddce13ce81d ("crypto: api - Add reqsize to crypto_alg") introduced cra_reqsize field in crypto_alg struct to replace type specific reqsize fields. It looks like this was introduced specifically for ahash and acomp from the commit description as subsequent commits add necessary changes in these alg frameworks. However, this is being recommended for use in all crypto algs instead of setting reqsize using crypto_*_set_reqsize(). Using cra_reqsize in aead algorithms, hence, causes memory corruptions and crashes as the underlying functions in the algorithm framework have not been updated to set the reqsize properly from cra_reqsize. [1] Add proper set_reqsize calls in the aead init function to properly initialize reqsize for these algorithms in the framework. [1]: https://gist.github.com/Pratham-T/24247446f1faf4b7843e4014d5089f6b

References

Community reviews

Loading reviews…