CVE-2025-68786: Linux kernel · ksmbd: skip lock-range check on equal size to avoid size==0 underflow
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.8.0-1052.55~22.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 12:55 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1052.55~22.04.1, 6.8.0-1059.65~22.04.1, 6.8.0-1054.57~22.04.1 +40
Exploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by the vendor. Users should update their Linux kernel to versions 6.8.0-1051.51~22.04.1 or later as provided by their distribution's security updates. After applying the update, a system reboot is required to ensure the fix is active.
Description
A vulnerability in the Linux kernel's ksmbd component caused an integer underflow when the size parameter was zero during a lock-range check. This issue was fixed by skipping the lock-range check when the size equals the current file size, preventing the underflow. The vulnerability affects certain Linux kernel versions prior to 6.8.0-1051.51~22.04.1 and similar builds. The issue has been addressed in official updates, and users should apply these patches and reboot to remediate the risk.
References
- ubuntu.com/security/CVE-2025-68786 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68786 (opens in a new tab)
- git.kernel.org/linus/5d510ac31626ed157d2182149559430350cf2104 (opens in a new tab)
- git.kernel.org/stable/c/52fcbb92e0d3acfd1448b2a43b6595d540da5295 (opens in a new tab)
- git.kernel.org/stable/c/571204e4758a528fbd67330bd4b0dfbdafb33dd8 (opens in a new tab)
- git.kernel.org/stable/c/5d510ac31626ed157d2182149559430350cf2104 (opens in a new tab)
- git.kernel.org/stable/c/a6f4cfa3783804336491e0edcb250c25f9b59d33 (opens in a new tab)
- git.kernel.org/stable/c/da29cd197246c85c0473259f1cad897d9d28faea (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8184-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8185-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8203-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8204-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8185-2 (opens in a new tab)