Skip to main content
VulnerabilityPublished Updated

CVE-2025-68802: Linux kernel · drm/xe: Limit num_syncs to prevent oversized allocations

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 6.17.0-1012.12~24.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1012.12~24.04.1, 6.17.0-1013.13~24.04.1, 6.17.0-22.22~24.04.1 +11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-22.22
Fixed in
  • 6.17.0-22.22
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1013.13
Fixed in
  • 6.17.0-1013.13
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vulnerability has been fixed by limiting num_syncs to 1024 in the drm/xe subsystem. Users should update to patched kernel versions at or beyond 6.17.0-1012.12~24.04.1 or equivalent. After updating, a system reboot is required to apply the fix.

Description

A vulnerability in the Linux kernel's drm/xe subsystem allowed userspace to specify an excessively large num_syncs value in exec and vm_bind ioctl calls, leading to oversized kernel memory allocations and warnings from the page allocator. This issue was addressed by introducing a limit (DRM_XE_MAX_SYNCS set to 1024) to reject requests exceeding this threshold. The vulnerability affects certain Linux kernel versions prior to 6.17.0-1012.12~24.04.1, 6.17.0-1013.13~24.04.1, 6.17.0-1018.18, 6.17.0-1020.20, and 6.17.0-22.22~24.04.1. A patch is available and should be applied to mitigate the issue.

References

Community reviews

Loading reviews…