Skip to main content
VulnerabilityPublished Updated

CVE-2025-68803: Linux kernel · NFSD: NFSv4 file creation neglects setting ACL

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-68803· High 8.0

Not known to be exploited · CVSS 8.0 High · fixed in 5.15.0-1103.110~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +71
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-22.22
Fixed in
  • 6.17.0-22.22
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1013.13
Fixed in
  • 6.17.0-1013.13
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions to ensure correct ACL handling during NFSv4 file creation. The vendor advisory confirms that this issue is fixed in updated kernel releases. Users should update their Linux kernel to the fixed versions as provided by their distribution.

Description

A vulnerability in the Linux kernel's NFSv4 server (NFSD) causes file creation to neglect setting the requested POSIX ACL, violating RFC 8881. When an NFSv4 client sets an ACL with a named principal during file creation, the ACL returned is only a default one derived from mode bits, not the one specified. This occurs because the kernel function nfsd_attrs_valid() does not recognize POSIX ACL changes, causing the ACL not to be applied. This issue affects specific Linux kernel versions and has been resolved with a patch.

References

Community reviews

Loading reviews…