Skip to main content
VulnerabilityPublished Updated

CVE-2025-68816: Linux kernel · net/mlx5: fw_tracer, Validate format string parameters

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-68816

Not known to be exploited · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 12:55 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +70

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-22.22
Fixed in
  • 6.17.0-22.22
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1013.13
Fixed in
  • 6.17.0-1013.13
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected linux-hwe-edge kernel versions. The vendor advisory from Ubuntu confirms that this issue has been fixed in updated kernel releases. Users should update to the fixed kernel versions to mitigate this vulnerability. No additional mitigation steps are indicated beyond applying the official kernel updates.

Description

A vulnerability in the Linux kernel's mlx5 firmware tracer component allowed malformed format strings from device firmware to cause crashes or undefined behavior. The issue was addressed by adding validation to restrict format specifiers to safe integer and hex types, rejecting unsafe ones. This prevents potential security issues caused by bad firmware providing malicious format strings. The vulnerability affects certain versions of the linux-hwe-edge kernel prior to specific patch releases.

References

Community reviews

Loading reviews…